Troubleshooting Issues Using Impinj Speedway Antenna Hub with Impinj Speedway Series

Are you having any of the following issues when using the Impinj Speedway Antenna Hub with Impinj Speedway series?

  • Reader's power and status LEDs are solid green, but you have intermittent connection to the reader's Web UI and RShell interface
  • A second Impinj Speedway antenna hub is showing up in the reader's web UI even though you're only using one
  • You're getting intermittent tag reads from antennas connected at the Impinj Speedway antenna hub or directly to the reader's four root antenna ports
  • Tag reads are reported on the wrong antenna port number

If you answered yes, then there could be a problem with your setup and/or hardware.  Here are some  troubleshooting steps to follow and recommended actions.

1) Are you using an Impinj Speedway R420 RAIN RFID reader or an Impinj Speedway R120 RAIN RFID reader?

  • The Impinj Speedway antenna hub product only works with our four-port or one-port Impinj Speedway series.

NOTE: Impinj announced EoL for Impinj R120. For more details, please see below:
https://support.impinj.com/hc/en-us/articles/360017638420-Impinj-Speedway-R120-Reader-End-of-Life-EOL-Product-Notice

2) Have you installed the latest Impinj Speedway reader firmware on the reader?

  • Your reader must be running software (Impinj Speedway firmware) version 4.10.0.240 or later.  Contact the Impinj partner who sold you your reader to get the latest firmware.

3) Have you enabled Impinj Speedway antenna hub on the reader?

  • Make sure you have enabled the Impinj Speedway antenna hub environment on your reader.  You can confirm this setting by checking the reader's web user interface and looking under the "ANTENNA HUB" section.  It should say "Enabled" next to Feature Status as shown in this screenshot:WebUI_Hub_Enabled.png
  • If you have not enabled Impinj Speedway antenna hub, then click the "Enable" button on the web UI.  
  • You can also enable Impinj Speedway antenna hub through RShell by issuing the following command at the RShell root command prompt:

         > config feature enable anthub

4) Reboot the reader

  • Please make sure you reboot the reader

     a) prior to starting to work with the Impinj Speedway antenna hub or

     b) after changing any configuration of the Impinj Speedway antenna hub.

5) Are you using the right GPIO adapter cable?

  • Impinj ships a one-foot HD15 cable with each Speedway GPIO Adapter kit (PN: IPJ-A6051-000). NOTE: this cable is NOT a VGA cable like you would use with a PC monitor.  Please don't use that kind of cable.  The proper cable to use with Impinj Speedway antenna hub is wired such that all pins are wired straight through.

    GPIO_Adapter_Cable.JPG

6) Is your Impinj Speedway antenna hub connected properly?

  • Let's test your setup with just one Impinj Speedway antenna hub.  Connect the HD15 GPIO Adapter cable between the reader's GPIO port and the GPIO Adapter box.  Connect a standard network (CAT5, etc.) cable between the GPIO Adapter box (port 1) and the Impinj Speedway antenna hub. Connect a coax cable between the reader's root antenna port 1 and the Impinj Speedway antenna hub.  Your setup should look similar to this:mceclip0.png
  • NOTE: please make sure your coax connectors are the correct type.  For example, make sure there is a center pin in the SMA connectors (SMA male).

7) Check Impinj Speedway antenna hub status through Reader's Web UI and/or RShell

  • From the reader's web UI, click on the "Show Connections" button in the ANTENNA HUB section. At the top of this screen, click the "Check Connections" button. If everything is working correctly, you will see a green check mark icon over the Impinj Speedway antenna hub (this is browser-dependent and it may not always show) and the table below the picture will show only one hub connected, as shown below.

AntHubCheck.pngAntHubCheck_2.png

  • If you are seeing the red X icon over the Impinj Speedway antenna hub, please contact the Impinj partner who sold you the Impinj Speedway antenna hub hardware.  You may have a bad GPIO Adapter cable.
  • To check Impinj Speedway antenna hub status in RShell, type the following command at the root RShell prompt:

         > show anthub summary

  • Something similar to the following will be displayed:    
     Ant_Hub_RShell_Screenshot.png
  • If you see "AntennaHub[n]ConnectionStatus='Connected'" and "AntennaHub[n]Fault='RF power'", please contact the Impinj partner who sold you the Impinj Speedway antenna hub hardware.  You may have a bad GPIO Adapter cable.
  • Optional check: If you want to confirm that the GPIO Adapter cable is the problem, check for continuity on each pin of the HD15 cable.  This cable should be wired such that all 15 pins are wired straight through.  If you find any of them shorted to the frame or each other, then you have a bad cable.
Was this article helpful?
0 out of 0 found this helpful

Comments

0 comments

Article is closed for comments.